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1 Scope 

1.1 Purpose of Document 
This document is a supplement of the installation manual with FOUNDATION Fieldbus specific 
items. 



 
 

1.2 Applicable Documents 
This document should be read in conjunction with the following documents: 
 
Ref. Title File name Version 

[1] NI-FBUS Configurator User Manual Part Number 370514C-01 Feb. 2004 
[2] FOUNDATION fieldbus Technical Specifications FF-007 V6.0 

Table 1-1 : Applicable Documents 



 
 

 

2 FF Application Guide with NI-FBUS Configurator 

2.1 Necessary equipment 
You need following equipment to use the NI-FBUS Configurator: 
- FOUNDATION Fieldbus instrument (DUT) 
- FOUNDATION Fieldbus H1 interface card (e.g. National Instruments AT-FBUS, 

PCMCIA-FBUS, PCI-FBUS) 
- Power Hub (e.g. Relcom Inc. FCS-PH-CC) 
- PC or laptop with Configuration Software (e.g. NI-Configurator) 

 

Optional NI-Bus Monitor with
FF PCMCIA Interface Card

NI-Configurator with
FF PCI Interface Card

Optional second FF Device
with AO Block and
Link Master Capability

Dräger Polytron
FF Basic Device

H1 Network
Example

Device
DescriptionPower Hub

 
Figure 2-1 : Example Setup of FOUNDATION Fieldbus H1 Network 

2.2 Overview 
General - FOUNDATION fieldbus is an all-digital, serial, two-way communication system 
that serves as a Local Area Network (LAN) for factory/plant instrumentation and control 
devices. FOUNDATION fieldbus is designed to be compatible with the officially sanctioned 
SP50 standards project of the ISA (The International Society for Measurement and Control) 
and the specifications of the IEC (International Electrotechnical Committee). The 
FOUNDATION specification is based on the ISO/OSI layered communications model, and 
consists of three major functional components: the Physical Layer, the communication 
"stack," and the User Layer. 
 
Network - H1 (31.25 kbit/s) interconnects “field” equipment such as sensors, actuators and 
I/O. HSE (100 Mbit/s) (High Speed Ethernet) provides integration of high speed controllers 
(such as PLCs), H1 subsystems (via a linking device), data servers and workstations. 
 
Devices - There are two device type in the FOUNDATION fieldbus specification: 
- Basic Device 
- Link Master - Link Master devices are capable of becoming the Link Active Scheduler 
(LAS - The Link Active Scheduler controls and schedules the communication on the bus). 
Basic Devices do not have the capability to become the LAS 
 



 
 

Terminal blocks - Terminal blocks can be the same terminal blocks as used for 4-20 mA. 
The terminal blocks typically provide multiple bus connections, such that a device can be 
wired to any set of bus terminals. 
 
31.25 kbit/s Fieldbus Signaling - FOUNDATION Fieldbus is using the special physical layer 
according to the standard IEC 61158-2. Fieldbus signals are encoded using the well-known 
Manchester Biphase-L technique. The transmitting device delivers ±10 mA at 31.25 kbit/s 
into a 50 ohm equivalent load to create a 1.0 volt peak-to-peak voltage modulated on top of 
the direct current (DC) supply voltage. The DC supply voltage can range from 9 to 32 volts. 
However, for Intrinsically Safe (I.S.) applications, the allowed power supply voltage depends 
on the barrier rating. 31.25 kbit/s devices can be powered directly from the fieldbus and can 
operate on wiring previously used for 4-20 mA devices. The 31.25 kbit/s fieldbus also 
supports I.S. fieldbuses with bus powered devices. To accomplish this, an I.S. barrier is 
placed between the power supply in the safe area and the I.S. device in the hazardous area. 
To address Intrinsic Safety applications, the Fieldbus Foundation supports using either the 
traditional Entity model or the newer Fieldbus Intrinsically Safe Concept (FISCO). The 
mixing of the Entity model with the FISCO approach in the preparation of a system design is 
not recommended. The 31.25 kbit/s fieldbus allows stubs or “spurs”. The length of the 
fieldbus is determined by the communication rate, cable type, wire size, bus power option, 
and I.S. option. 
 
Software - NI-FBUS Configurator is a Windows (2000/NT/XP) application that provides tools 
for complete configuration of FOUNDATION Fieldbus segments. NI-FBUS Configurator 
automatically detects devices when you connect them to fieldbus; and they go online. 
Function Block Configuration - You can automatically or manually configure device tags to 
meet your requirements. When connected to a fieldbus network or after loading an existing 
configuration from disk, NI-FBUS Configurator displays all the function blocks available 
within a device. NI-FBUS Configurator recognizes all standard blocks as well as any 
manufacturer-specific custom blocks found in a device and included in the device 
description. Schedule Creation - NI-FBUS Configurator automatically generates the optimal 
execution schedule for function blocks and communication between function blocks. 
Other host systems (PLCs) are the Yokogawa CENTUM CS 3000, Emerson Delta V, ABB 
System 800xA or Freelance 800F, smar SYSTEM302 or Honeywell Experion. 
 
Tools - The National Instruments NI-FBUS Monitor is a 32-bit Windows (2000/NT/XP) 
application used for monitoring of traffic on FOUNDATION Fieldbus networks. NI-FBUS 
Monitor uses an NI FBUS interface device to interface to an H1 network, and is useful for 
system diagnostics because with it you can selectively capture and view different types of 
data packets on Fieldbus. 



 
 

2.3 Setup FOUNDATION Fieldbus Device Jumpers 
The FOUNDATION Fieldbus device is equipped with two jumpers. One hardware jumper will 
be provided on fieldbus device to disable the simulate parameter. If this jumper is removed, 
then simulate parameters of all input and output blocks within a resource will be disabled. 
This jumper will be provided to prevent simulation from accidentally being enabled during 
plant operations. Adding this jumper to a device will force the Simulate Active attribute of the 
Block error parameter in the Resource Block to be set active. 
 
The other hardware jumper activate write-locking, the write-lock jumper must be removed 
and the Hard Write Lock Supported bit in FEATURE_SEL must be set. When this is 
detected by the device, all writes to static and non-volatile parameters will be rejected by the 
device during this state. To deactivate write locking, since FEATURE_SEL is not writeable 
during write locking, the jumper must be set. 
 
Refer to chapter 3.2 for diagnostic the status of the jumpers. In case of the Dräger Polytron 
device the jumpers are located at a Dongle slot on the interface board. 
 
 

Figure 2-2 : FOUNDATION Fieldbus Jumpers 
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2.4 Setup the FOUNDATION Fieldbus interface card 
You can use the FOUNDATION Fieldbus interface cards AT-FBUS or PCI-FBUS for desktop 
computers or PCMCIA-FBUS for laptop computers. After installing the card in the computer 
open the Interface Configuration Utility and add/configure the interface card according to the 
corresponding installation manual. Verify the interface card is configured for the usage as 
NI-FBUS. 
 

 
Figure 2-3: Set FOUNDATION Fieldbus Interface Card 

 
It is possible that the interface card provide two ports. In this case one port should be at 
least enabled. For this purpose click on the board symbol with a right mouse click and 
enable the Port. 
 

 
Figure 2-4 : Enable Ports 

 



 
 

2.5 Import Device Description and Capabilities File  
To define the device information, the FOUNDATION Fieldbus device is supplied with three 
device support files: Two Device Description Files (FFO and SYM) and one Capability File 
(CFF). 
The DD provides information needed for a control system or host to understand the 
meaning of the data in the VFD including the human interface for functions such as 
calibration and diagnostics. Thus, the DD can be thought of as a “driver” for the device. 
 
Click "Import DD/CFF" in the main window of the Interface Configuration Utility. An "Import 
DD/CFF" dialog box will prompt you to select your DD and CFF files. To import CFF file 
together with DD files, change the "Files of type" to "All Files(*.*)" and select the CFF file. 
The DD file of the same device must exist in the same folder with the DD file, -otherwise, an 
error will occur. 
 

 
Figure 2-5: Import DD and CFF 

2.6 Using the NI-FBUS Configurator 

2.6.1 Create New Project 

Select Start»Programs»National Instruments»NI-FBUS» NI-FBUS Configurator to start the 
NI-FBUS Configurator and when prompted, click Yes to start NIFB.EXE. 
or 
Select Start»Programs»National Instruments»NI-FBUS»NI-FBUS Communications Manager 
to start the NIFB process,then select Start»Programs»National Instruments»NI-FBUS»NI-



 
 

FBUS Configurator. Refer to your getting started manual for more information about the 
NIFB process. 
When you start the NI-FBUS Configurator, the Start Up dialog box appears automatically. If 
you want to create a new project at any other time, select File»New. 
In the Start Up dialog box, each configured interface will appear. Select the link(s) (ports on 
your Foundation Fieldbus interface) you want to include in your project in the Added Link(s) 
checklist. In this case select checkbox of interface 0-0. 
 

 
Figure 2-6 : NI-FBUS Configurator - Create New Project 

The device will appear in the device tree if it is connected in the right way and has finished 
the power-up sequence. 
 
Note: If the device is online for the first time or the device is reset (refer to chapter 3.3), it 
will appear with a temporary address. In this case the Link Master (NI-FBUS Configurator) 
tries to set a permanent address to the device. This process may take a few minutes or 
longer, because the device will be restarted several times. 
 
Double click on the device node in the device type tree. In the right frame the device 
information will appear. The tag (PD_TAG) and the node address of device can be changed 
manually. Refer to chapters 2.6.2 and 2.6.3. 
 

 
Figure 2-7 : NI-FBUS Configurator - Device Information 

2.6.2 Change Tags 

If you have multiple host machines, setting a device or block tag may affect how other host 
machines on an operating network access a device. There are three ways to change a tag. 
 

- In the configuration tree, right-click the device or block whose tag you want to 
change and select Set Tag. 
- Select the object menu item from the main menu bar and select Set Tag. 
- Double-click the device or block in the configuration tree to launch the block 
configuration window. Then, click the Device Tag field in the block configuration window. 

 



 
 

 
Figure 2-8 : NI-FBUS Configurator - Set Tag (Menu) 

 
In the New Tag field, type the tag you want to assign. Make sure the Set to OOS Mode 
checkbox is selected. Be aware that when you set the device tag, the device loses all 
linkage and communication configuration information and loses control of the process. You 
should not change device tags after you have configured your process. 
Click the Set button. The NI-FBUS Configurator sets the block or device to OOS mode 
before setting the new tag. If the device or block does not go to OOS mode, the NI-FBUS 
Configurator notifies you and you must determine whether to continue to set the tag. You 
should not try to set the tag without putting the device in OOS mode. Note It may take a few 
minutes for the tag to set. 

 
Figure 2-9 : NI-FBUS Configurator - Set Tag (Change) 



 
 

2.6.3 Change Address 

In the configuration tree, right-click the device whose address you want to set and select Set 
Address. The Set Address dialog box appears. 
In the New Address field, select the desired address from the drop-down list, as shown in 
the following figure. 

 
Figure 2-10 : NI-FBUS Configurator - Set Address (Menu) 

Check the Set to OOS Mode checkbox. Doing so sets the block to out of service (OOS) 
mode, which prevents the device from operating in its current control system. 
When you set the device address, the device loses all linkage and communication 
configuration information and loses control of the process. You should not change a device 
address after you have configured and are running your process. Click the Set button. 
 

 
Figure 2-11 : NI-FBUS Configurator - Set Address (Change) 



 
 

2.6.4 Change Block Mode 

The operational modes for the blocks on the device are Automatic (Auto), and Out Of 
Service (OOS). The function block supports additionally the mode Manual (Man). There are 
two ways to change the target mode of a block. 
 

- Double-click the block and select via the buttons the desired target mode. 
- Double-click the block and select via the parameter MODE_BLK.Target in the tab 
Process the desired target mode. 

 

 
Figure 2-12 : NI-FBUS Configurator – Mode 

 Note : If the mode of the resource block is changed to Out-of-Service (O/S). In this state the 
actual mode of the transducer and function block in the resource will be forced to O/S mode. 



 
 

2.6.5 Modify and write a parameter 

Use the cursor to select the parameter value you want to change. In many cases, you can 
select the desired setting from a drop-down menu, or type in the new value. If a parameter 
value is greyed out, it is read-only and you cannot change it. After you change a parameter 
value, an asterisk (*) appears by the parameter name and the field turns yellow. 

 

 
Figure 2-13 : Write parameters (1) 

 
To make your changes effective immediately, click the Write/Save Changes button on the 
block configuration window toolbar. If the device accepts the new setting, the asterisk and 
yellow colour will clear. If the device does not accept the new setting, you are probably 
trying to write a setting that is invalid for your device. 

 

 
Figure 2-14 : Write parameters (2) 

2.6.6 Configure the Transducer Block 

The transducer block provide the main process value for the function block, in case of the 
Dräger Polytron the main process value is the gas concentration of the configured gas. Via 



 
 

the transducer block the measured gas can be selected (by parameter GAS_INDEX or 
Method “Gas Selection”). 
 

 
Figure 2-15 : Transducer Block - Others 



 
 

2.6.7 Configure Function Block Application 

The function block receive the sensor value from the transducer block and provide this for 
the whole plant application. Thereby the sensor value can be formatted and scaled by the 
function block. 
 
Configure the Analog Input Function Block - There are two ways to open the block 
configuration window of a block: 
 
- Double-click the name of the function block under the appropriate device in the 
configuration tree. 
- Double-click a function block in the Function Block Application Editor window. 
 
The block configuration window appears floating over the main window. A block 
configuration window is shown. You can change parameter settings either by clicking the 
desired field and typing the new value or by selecting the new value from a pull-down menu. 
Changing Parameter Settings from AI- Function block in following manner: 
 
1. Set the target mode of AI Block into OOS mode. Verify only OOS is selected at 
MODE_BLK.Target. 
2. Select the Process tab 
3. Go to CHANNEL and choose “Gas Concentration” 
 

 
Figure 2-16 : Analog Input Function Block - Process Configuration 

 

1. 
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4. Select the Scaling tab 
5. Go to L_TYPE and choose “Direct” 
6. Go to XD_Scale and choose UNITS_INDEX to be “ppm” 
7. Go to OUT_SCALE and choose UNITS_INDEX to be “ppm” 
8. Set the 0% and 100% scale to be the same as the PRIMARY_VALUE_RANGE in the 
transducer block. 
9. At least the Analog Input Function Block must be downloaded within in a schedule, refer 
to chapter 2.6.8 and 2.6.9. It is sufficient that the Analog Input Function Block is part of the 
Function Block Application. 
 

 
Figure 2-17 : Analog Input Function Block - Scaling Configuration (2) 

 
 Note: The decimal statement for display purposes is not used by the NI-FBUS Configurator. 
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10. Select the Diagnostic tab and verify the block error displays no “Block Configuration”, 
which means there is an error detected in the block configuration. Note: “Block 
Configuration” is also displayed if the Analog Input Function Block is not downloaded within 
a schedule, refer to item 9. 
11. Put the AI Block back into Auto mode. 
 

 
Figure 2-18 : Analog Input Function Block - Diagnostic 

Now the OUT Value should display the gas concentration. The PV should be equal to the 
PRIMARY_VALUE of the transducer block and the FIELD_VAL displays the value that is 
calculated in percent. 

 
Figure 2-19 : Analog Input Function Block – Process Values 

2.6.8 Create Function Block Application 

To open the Function Block Application Editor window, double-click the Function Block 
Application icon in the configuration tree. 

10. 

9. 



 
 

Add Blocks to the Function Block Application - Drag blocks from the device tree to the 
Function Block Application Editor until all the blocks you want to use are in the Function 
Block Application Editor. The following figure shows how the Function Block Application 
Editor looks with function blocks dragged onto it. In this example we use Analog Output 
Function Block from SMAR device. 
 

 
Figure 2-20 : Function Block Application 

 
Connecting Blocks - To send data from one block to another, you must connect the outputs 
and inputs. You can wire blocks manually or use a template. The help window on the right 
side of the screen describes the input and output parameters and how they can be 
connected. To wire blocks manually, complete the following steps: Click the Wiring tool on 
the Function Block Application Editor toolbar. Click one terminal you want to connect. To 
tack down the wire at different points, click in the background of  the Function Block 
Application Editor window. Click the terminal to which you want to wire. 
 
Checking for Function Block Application Errors - Click the Check Project for Errors button in 
the Function Block Application Editor window to perform error checking, regenerate the 
schedule of the application, and remove bad wires. 
 
View and Edit a Schedule - The NI-FBUS Configurator automatically determines the 
execution order and timing of the schedule based on your control strategy, network and 
device factors, and the loop execution rate you choose. The NI-FBUS Configurator also 
automatically optimises the schedule. The following figure shows how the NI-FBUS 
Configurator displays multiple loops in the schedule window. 
 

 
Figure 2-21 : Function Block Schedule 

Wiring Tool 
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2.6.9 Download the Project Configuration 

Before function blocks will execute on the device, the configuration must be downloaded to 
the devices. Function block linkages must be downloaded to allow dataflow from one block 
to another. Also, the schedules for function block execution and communication have not yet 
been provided to the devices. Complete the following steps to download your project 
configuration. 
 
1. Click the Download Project button in the configuration tree toolbar or select 
Configure»Download Configuration. The Download Configuration dialog box appears. 
2. Select the configuration object to download. (Can be greyed and read-only) 
3. If you have not done so already, click the Link Masters button to set link masters to 
receive the primary Link Active Scheduler, the primary time master of the link, and the Link 
Active Schedule. The Network Parameters dialog box appears. 
 

 
Figure 2-22 : Download the Project Configuration 

 
4. (Optional) Check the appropriate checkboxes for the download options. Refer to the 
Download Options section for more information. In general, you should use Clear Devices 
and Automatic Mode Handling on all downloads. 
5. To download your configuration changes to the network, click the Download button. The 
Download Status progress bar shows what percentage of the configuration is complete. 
While downloading, the NI-FBUS Configurator displays and updates the Download tab in 
the status window. It shows what device is currently being configured, its settings, and 
whether it was successfully configured. 

2.6.10 Configure Alarms 

You can configure the interface card to receive alarms generated by the blocks. 
 
1. Drag the configuration tree icon for the interface to which you want to send the alarm to 
the Function Block Application Editor, if you have not done so already. 
2. Either wire the Alarms output of the block that you want to generate an alarm to the 
device you want to receive the alarm, or check the Receive All Alarms box, if the device has 

1. 

2.

3. 

4. 

5. 



 
 

one. The following figure shows an example of a configured alarm. Download  the new 
configuration, refer to chapter 2.6.9. 
 

 
Figure 2-23 : Alarm Configuration 

 
3. If necessary configure the alarm. For example we configure the limit alarms of the 
function block and the “relays” alarms of the transducer block. 
4. Double-click the Analog Input function block, the block configuration window appears. In 
the block configuration window, click the Alarms tab to view or change alarm information, 
such as the high and low limits of an alarm condition, alarm priorities, and so on. 
 

 
Figure 2-24 : Analog Input Function Block - Alarms 

5. Double-click the Transducer block, the block configuration window appears. In the block 
configuration window, click the Alarms tab to view or change alarm information 



 
 

 

 
Figure 2-25 : Transduce Block - Device Specific Alarm Configuration 

2.6.11 Monitor Alarms 

The NI-FBUS alarm monitor utility lets you capture, view and acknowledge the alarm 
omitted by the device. You can run the NI-FBUS alarm monitor utility by selecting 
Start»Programs»National Instruments»NI-FBUS»NI-FBUS Alarm Monitor Utility. 
 
- Click the Start Capture button on the toolbar, or select Run»Start to start the alarm 
monitor.  
- When an alarm is captured, the Unacknowledged Alarms dialog box will appear. Click 
the Act button to acknowledge the selected alarm. Click Act All to acknowledge all of the 
alarms in the dialog box. 
- You can automatically acknowledge the alarm by selecting Run»Auto Acknowledge or 
click the Auto Acknowledge button on the toolbar (if this option is checked, the 
Unacknowledged Alarms dialog box will not appear after an alarm is captured). 
- Click the Reset Capture button on the toolbar, or select Run»Reset to clear currently 
captured alarms. 
- Refer to NI-Configurator Manual to learn more about the NI-FBUS Alarm Monitor. 
 



 
 

 
Figure 2-26 : NI-FBUS Alarm Monitor 

Note : Sometimes the NI-FBUS Alarm Monitor does not receive the alarms and so it could be 
necessary to restart the whole NI application (Close and restart NI-Configurator and NI-
Communication Manager). This should be a application problem. 

2.6.12 Configure Trends 

You can configure a device, such as an interface in a PC, to receive trends from function 
blocks. 
1. Drag the configuration tree icon for the device or interface to which you want to send the 
trend to the Function Block Application Editor, if you have not done so already. 
2. Either wire the Trends output of the block to the device you want to receive the trend, or 
check the Receive All Trends box, if the device has one. The following figure shows an 
example of a configured trend. Download the new configuration, refer to chapter 2.6.9. 
 

 
Figure 2-27 : Trend Configuration 

 
3. Double-click the function block from which you want to send a trend. The block 
configuration window appears. 
4. In the block configuration window, click the Trends tab. 
5. Check the Trend column checkbox next to the parameter you want to trend. 
6. Set the sample Interval of the trend in loops/sample. The interval should be a multiple of 
any loop macrocycle time in which this block is involved. For example, if the interval is 2 
loops/sample, and the loop macrocycle time is 1 s, the trend will acquire a value every 2 s. 
7. Set the Sample Type. Select Instant or Average from the Sample Type drop-down list. 
Instant trends the actual value. Average trends all samples. 

 

Start 
Auto Acknowledge 



 
 

 
Figure 2-28 : Analog Input Function Block – Trends 

 
Note: The Draeger P7xxx FF device only supports one trend. If more than one trend is 
enabled, the NI-Configurator will notify NIF_ERR_TREND_FULL. 

2.6.13 Monitor Trends 

The NI-FBUS trend monitor utility lets you capture and view the trends of parameters 
omitted by the device. You can run the NI-FBUS trend monitor utility by selecting 
Start»Programs»National Instruments»NI-FBUS»NI-FBUS Trend Monitor Utility. 
 
- Click the Start Capture button on the toolbar, or select Run»Start to start monitoring the 
trends. When a trend is captured, a line is added into the screen view to trace the trend. An 
item is also added into the attribute view to give the parameter information and the line’s 
attribute. 
- In the screen view, click the top bottom item on the vertical axis to adjust vertical scope. 
Change the Elapsed Time edit box on the toolbar to adjust the visible time scope of screen 
view, which is the indication amount of the horizontal axis. Click the Autoscale button on the 
tool bar or select Run»Autoscale to reset the vertical axis to the default values. 
- Click the Stop Capture button on the toolbar, or select Run»Stop to stop trend 
monitoring. Click the Reset Capture button on the toolbar, or select Run»Reset to clear the 
captured trends. 
- Refer to NI-Configurator Manual to learn more about the NI-FBUS Trend Monitor. 
 



 
 

 
Figure 2-29 : NI-FBUS Trend Monitor 

2.6.14 Offline Configuration 

During creation of a new project select the Offline Configuration interface in place of the 
normal interface. You can add offline devices to the offline link by completing the following 
steps: 
 
1. Select the Window»Device Type Window menu item if the device type window is not 
already shown. 
2. Drag the offline device you want to add to the offline link from the device type tree in the 
left-hand window and drop it onto the active offline link of the configuration tree in the project 
window. 
 

 
Figure 2-30 : NI-Configurator - Offline Configuration 

Now the blocks and the Function Block Application can be configured. Save the complete 
offline project. 
Additional the several block parameter values can be saved as “Default Configuration 
Parameter Values”. The following figures shows the part of a new configured function block. 
Amongst others the channel is changed to “Sensor temperature” (tab “Process”) and the 
scaling parameters are changed. 
 

Click to Adjust 
Auto Scaling 



 
 

 
Figure 2-31 : Analog Input Function Bock - Offline Configuration 

The other possibility to save parameter values for further configuration is to use the Import 
and Export functionality. For this purpose right-click the device in the configuration tree and 
select either export or import parameters. 
 

 
Figure 2-32 : Import or Export Parameter Values 

 
Taking a link online moves an offline link to an online state. Generally, it occurs before you 
download the offline configuration to the field network. 



 
 

 
1. Select the offline link and click the Take Online button on the toolbar, or right click the 
offline link and select Take Online. 
2. In the Assign Devices dialog box, select the online link to which you want to connect in 
the Select Online Link combo-box. 
3. After the online link loads completely, select the online device from the Device List 
window which will be assigned to the selected offline device. 
4. Click within the Target Address column to select the address the selected online device 
will be assigned. 
5. Click the Refresh Link button to completely reload the selected online link. 
6. Select the Assign Network Parameters option to assign network parameters. 
 
Note: The whole process may take a few minutes or longer. 
 

 
Figure 2-33 : Offline Configuration - Go Online 
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3 Diagnostics 

3.1 Error Diagnostic 
There are several parameters to verify if there is any error in the device. To get more 
information about the errors refer to the NI-Configurator Manual, FW-Requirements Error 
Mapping or to Fieldbus Specification. 

3.1.1 Block Error 

The block error parameter reflects the error status of hardware or software components 
associated with and directly impact the correct operation of a block. 

 
Figure 3-1 : Block Error 

3.1.2 Transducer Block Error 

The transducer block has an additional XD_ERROR parameter to verify the error status. 



 
 

 
Figure 3-2 : Transducer Block - XD_ERROR 



 
 

3.1.3 Device Specific 

The resource block contains additional parameters for diagnostic. The fieldbus module 
status reflects the status of the fieldbus software modules. The device status parameter 
indicates if there is any error or warning in the Polytron or sensor module. There are 
additional parameters to show each value in the error matrix. Also the corresponding 
method can be used, to display the whole matrix. 
 

 
Figure 3-3 : Device Specific Error Diagnostic 



 
 

3.2 Status of jumpers 
If the simulation is active (Jumper is set) the BLOCK_ERR of the resource block displays 
“SimulationActive” otherwise and during normal operation the BLOCK error should display 
0x0000. If the write protect is not active (Jumper is set) the WRITE_LOCK of the resource 
block displays “Not Locked” otherwise (Jumper is not set) and “Locked”. 
 

    
Figure 3-4 : Resource Block – Simulation and Write Protect Status 



 
 

3.3 Restart device 
You can do a software restart of a device on-board processor by double-clicking the device 
resource block. Under the Options tab, you should find a RESTART parameter. There are 
three entries in the list: 
 

1.  “Processor” will restart the processor. The device in the configuration tree will be 

marked with following symbol , because the device restarts and so the Master has 
lost the connection. An additional window appears with the message 
“NIF_ERR_OBSOLETE_DEVICE”. After a short while the symbol should disappear 
the device should be reinitialised. 

2. “Resource” will restart the resources of the device. This has no affect at the P7xxx 
device. 

3. “Default” will reset the fieldbus specific parameters to the default values and delete a 
possible loaded schedule. 

 

 
 
 

Figure 3-5 : Resource Block – Restart 

For some reason’s it might be useful to be able to clear the complete non volatile memory 
content. The device then starts-up with an none initialized non volatile memory and loads its 
default-configuration (include address and tags). 

 
For this the device has a hidden RESTART parameter which is not available via the DD. To 
reset the non volatile memory proceed as follows: 
 

1. Start the NI-FBUS Dialog Utility. Start»Programs»National Instruments»NI-BUS»NI-
FBUS Dialog Utility. 

2. Select  first “Open Session” then “Expand All” from the “Actions-Menu” 
3. Select the “RESOURCE” of the device 
4. Right click the mouse and select “GetParamList” from the context menu 
5. Select the “RESTART” parameter. 
6. Select “Write” in the first window and “EditData” in the second windows 
7. Set the value to “42” 
8. “Write” the value 

 



 
 

The error message  “A communications failure has occurred” will appear”. This is ok 
because the processor has been reset. Close in a short while the NI-Communication 
Manager. 
 

 
Figure 3-6 : Reset non volatile memory 


